Point sensor makes the simulation diverge?

This post is deleted!

It is possible that both simulations are performing equally well (or equally bad...). One major difference is that the "Convergence" that you see in the task manager is computed differently: in one case it includes the edge sensors at the source and the overall field, in the other case it includes the edge sensors, the overall field, AND the point sensor. The latter is a bit "stricter" and it may detect divergence sooner (or rather "non-convergence", since the simulation has not actually diverged).

my suggestions:

  • try running for more periods and/or use automatic convergence
  • upgrade to Sim4Life 4.4

The first file is the tutorial "3.1.7 Generic MRI System and Lead Pass" which it converges. The second one is exactly the same as the first one, I just added a point sensor at the origin and it makes the simulation not converge.

I checked the plane wave simulation, tutorial " 3.3.4 Heating from a Standard Active Implantable Medical Device" with line sensor which is attached.

427eb6a5-2266-47f8-9ef2-b541d6981478_Input.log

b03661b0-9635-4ff8-93fa-7b9e220f6b89_Input.log

And it diverges too.

How I can use automatic convergence?

None of the simulations you have shown so far truly "diverge". They all finished successfully, as indicated at the end of those log files.
Note that this does not mean that the simulations "converged", nor that the results are correct.

In principle, simulations stop when one of the following happens:

  • the excitation signal was sustained for the desired amount of time (you can see what your current settings are by clicking Source Signal button in the ribbon)
  • the simulation diverges (the numerical scheme becomes unstable and values go to infinity)
  • the solver returns an error (because of a license issue, incompatible hardware, no more space on hard drive, out of RAM, bug, etc...)
  • the solver detects that the simulation converged

Now the question is, what do you think happened in your examples?

Actually in the simulation I sent you, the convergence in the task manager goes up instead of going down. You mean if that happens, it does not mean the simulation does not converge?

Convergence, as plotted in the task manager, is computed as a rate of change of the quantities measured by the sensors:

  • when that number goes up, it means the simulation has not converged (yet?)
  • when it goes towards infinity exponentially fast, the simulation has diverged
  • when it goes below a given threshold (-50dB is the default setting), the simulation is said to have converged

Note (once again), that "convergence" depends on the sensors that have been set in the simulations, so adding a point sensor affects the "convergence" value reported in the task manager even if nothing else changes. For example, the rate-of-change of the field values reported by a point sensor placed far away from a source might go up when the traveling wave generated by the source reaches the point sensor.

To answer your question specifically: I don't know, because I can't see what you are doing. But try running the simulation for a longer time, then you'll know whether the simulation converges or diverges.

Thanks for your help.

Log in to reply